37 lines
995 B
Nix
37 lines
995 B
Nix
# This file defines overlays
|
|
{ inputs, ... }:
|
|
{
|
|
# This one brings our custom packages from the 'pkgs' directory
|
|
additions = final: _prev: {
|
|
# nest everything under a namespace that's not likely to collide
|
|
# with anything in nixpkgs
|
|
local-pkgs = import ../pkgs { pkgs = final; };
|
|
};
|
|
|
|
# This one contains whatever you want to overlay
|
|
# You can change versions, add patches, set compilation flags, anything really.
|
|
# https://nixos.wiki/wiki/Overlays
|
|
modifications = final: prev: {
|
|
};
|
|
|
|
unstable-packages = final: _prev: {
|
|
# use 'pkgs.unstable'
|
|
unstable = import inputs.nixpkgs-unstable {
|
|
system = final.system;
|
|
config.allowUnfree = true;
|
|
};
|
|
|
|
# use 'pkgs.stable'
|
|
stable = import inputs.nixpkgs-stable {
|
|
system = final.system;
|
|
config.allowUnfree = true;
|
|
};
|
|
|
|
master = import inputs.nixpkgs-master {
|
|
system = final.system;
|
|
config.allowUnfree = true;
|
|
};
|
|
};
|
|
|
|
lix = inputs.lix-module.overlays.default;
|
|
}
|